Re: [PATCH] pmdomain: core: Use genpd_is_irq_safe() helper

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, 29 May 2024 at 11:19, Geert Uytterhoeven
<geert+renesas@xxxxxxxxx> wrote:
>
> Use the genpd_is_irq_safe() helper instead of open-coding the same
> operation.
>
> Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>

Applied for next, thanks!

Kind regards
Uffe


> ---
>  drivers/pmdomain/core.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/pmdomain/core.c b/drivers/pmdomain/core.c
> index 1eae7b2317897f0b..01cf17789621a04f 100644
> --- a/drivers/pmdomain/core.c
> +++ b/drivers/pmdomain/core.c
> @@ -2082,7 +2082,7 @@ static void genpd_free_data(struct generic_pm_domain *genpd)
>
>  static void genpd_lock_init(struct generic_pm_domain *genpd)
>  {
> -       if (genpd->flags & GENPD_FLAG_IRQ_SAFE) {
> +       if (genpd_is_irq_safe(genpd)) {
>                 spin_lock_init(&genpd->slock);
>                 genpd->lock_ops = &genpd_spin_ops;
>         } else {
> --
> 2.34.1
>




[Index of Archives]     [Linux Samsung SOC]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]

  Powered by Linux