Hi Biju, On Mon, Mar 18, 2024 at 10:46 AM Biju Das <biju.das.jz@xxxxxxxxxxxxxx> wrote: > > From: Geert Uytterhoeven <geert@xxxxxxxxxxxxxx> > > On Fri, Mar 15, 2024 at 7:39 PM Biju Das <biju.das.jz@xxxxxxxxxxxxxx> wrote: > > > The RZ/G2L family SoCs has 10 PIPE buffers compared to 16 pipe buffers > > > on RZ/A2M. Update the pipe configuration for RZ/G2L family SoCs and > > > use family SoC specific compatible to handle this difference. > > > > > > Added SoC specific compatible to OF table to avoid ABI breakage with > > > old DTB. To optimize memory usage the SoC specific compatible will be > > > removed later. > > > > > > The pipe configuration of RZ/G2L is same as the default one, so reuse > > > the common table by renaming > > > usbhs_default_pipe[]->usbhs_rcar_default_pipe[] > > > and changing static qualifier to global to fill the pipe configuration > > > data. > > > > > > Signed-off-by: Huy Nguyen <huy.nguyen.wh@xxxxxxxxxxx> > > > Signed-off-by: Biju Das <biju.das.jz@xxxxxxxxxxxxxx> > > > --- > > > v2->v3: > > > * Updated commit description > > > * Dropped usbhsc_rzg2l_pipe[] and reusing the default_pipe[]. > > > > Thanks for the update! > > > > > --- a/drivers/usb/renesas_usbhs/common.c > > > +++ b/drivers/usb/renesas_usbhs/common.c > > > @@ -363,8 +363,8 @@ static void usbhsc_clk_disable_unprepare(struct usbhs_priv *priv) > > > * platform default param > > > */ > > > > > > -/* commonly used on old SH-Mobile SoCs */ -static struct > > > renesas_usbhs_driver_pipe_config usbhsc_default_pipe[] = { > > > +/* commonly used on old SH-Mobile and RZ/G2L family SoCs */ struct > > > +renesas_usbhs_driver_pipe_config usbhsc_rcar_default_pipe[] = { > > > > So why rename this to have "rcar" in the name? > > Oops, it is not used by R-Car, but used by old SH SoCs and RZ/G2L > As this structure becomes global now, Will use usbhsc_rzg2l_default_pipe[] instead?? > > Or > > Will make this as static like current driver and drop filling pipe configs in info and > use .has_new_pipe_configs to zero for devices using usbhsc_default_pipe[]?? I think just using .has_new_pipe_configs is the simplest solution. Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds