Re: [PATCH] thermal: rcar_gen3_thermal: Use devm_add_action_or_reset() helper

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, 2019-07-31 at 20:44 +0200, Niklas Söderlund wrote:
> Hi Geert,
> 
> Thanks for your work.
> 
> On 2019-07-31 14:50:53 +0200, Geert Uytterhoeven wrote:
> > Use the devm_add_action_or_reset() helper instead of open-coding
> > the
> > same operations.
> > 
> > Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
> 
> Reviewed-by: Niklas Söderlund <niklas.soderlund+renesas@xxxxxxxxxxxx>
> 
Hi, Geert,

https://patchwork.kernel.org/patch/11034969/ is the same fix submitted
a few days earlier, so I will take that patch instead. Thanks for the
patch anyway.

thanks,
rui

> > ---
> >  drivers/thermal/rcar_gen3_thermal.c | 7 +++----
> >  1 file changed, 3 insertions(+), 4 deletions(-)
> > 
> > diff --git a/drivers/thermal/rcar_gen3_thermal.c
> > b/drivers/thermal/rcar_gen3_thermal.c
> > index a56463308694e937..2db7e7f8baf939fd 100644
> > --- a/drivers/thermal/rcar_gen3_thermal.c
> > +++ b/drivers/thermal/rcar_gen3_thermal.c
> > @@ -443,11 +443,10 @@ static int rcar_gen3_thermal_probe(struct
> > platform_device *pdev)
> >  		if (ret)
> >  			goto error_unregister;
> >  
> > -		ret = devm_add_action(dev, rcar_gen3_hwmon_action,
> > zone);
> > -		if (ret) {
> > -			rcar_gen3_hwmon_action(zone);
> > +		ret = devm_add_action_or_reset(dev,
> > rcar_gen3_hwmon_action,
> > +					       zone);
> > +		if (ret)
> >  			goto error_unregister;
> > -		}
> >  
> >  		ret = of_thermal_get_ntrips(tsc->zone);
> >  		if (ret < 0)
> > -- 
> > 2.17.1
> > 
> 
> 




[Index of Archives]     [Linux Samsung SOC]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]

  Powered by Linux