Hi Niklas,
Thanks for your comment.
On 11/05/2016 04:32 PM, Niklas Söderlund wrote:
Hi Cao,
On 2016-11-04 17:38:54 +0900, Cao Minh Hiep wrote:
From: Hiep Cao Minh <cm-hiep@xxxxxxxxxxx>
This patch supports 32bytes of buffer for DUAL and QUAD in QSPI by
Using Transmit/Receive Buffer Data Triggering Number.
In order to improve the DUAL and QUAD's performance of SPI
while transferring data in PIO mode, it sends/receives each 32bytes
data instead of each byte data as current situation.
Signed-off-by: Hiep Cao Minh <cm-hiep@xxxxxxxxxxx>
---
drivers/spi/spi-rspi.c | 52 +++++++++++++++++++++++++++++++++++++++++++++++---
1 file changed, 49 insertions(+), 3 deletions(-)
diff --git a/drivers/spi/spi-rspi.c b/drivers/spi/spi-rspi.c
index a816f07..fb12bc5 100644
--- a/drivers/spi/spi-rspi.c
+++ b/drivers/spi/spi-rspi.c
@@ -413,7 +413,7 @@ static unsigned int qspi_set_send_trigger(struct rspi_data *rspi,
return n;
}
-static void qspi_set_receive_trigger(struct rspi_data *rspi, unsigned int len)
+static int qspi_set_receive_trigger(struct rspi_data *rspi, unsigned int len)
{
unsigned int n;
@@ -428,6 +428,7 @@ static void qspi_set_receive_trigger(struct rspi_data *rspi, unsigned int len)
qspi_update(rspi, SPBFCR_RXTRG_MASK,
SPBFCR_RXTRG_1B, QSPI_SPBFCR);
}
+ return n;
}
#define set_config_register(spi, n) spi->ops->set_config_register(spi, n)
@@ -514,6 +515,51 @@ static int rspi_pio_transfer(struct rspi_data *rspi, const u8 *tx, u8 *rx,
return 0;
}
+static int rspi_pio_transfer_in_or_our(struct rspi_data *rspi, const u8 *tx,
+ u8 *rx, unsigned int n)
Nitpicking, s/rspi_pio_transfer_in_or_our/rspi_pio_transfer_in_or_out/
or am I missing something?
You're right!. It should be "rspi_pio_transfer_in_or_out"
I'll update it in an other patch.
Thanks.
Jinzai Solution Inc,
Hiep.