On Mon, Apr 13, 2020 at 05:22:55PM +0300, Leon Romanovsky wrote: > From: Leon Romanovsky <leonro@xxxxxxxxxxxx> > > Hi, > > This series introduces simplified version of mlx5 command interface, > refactors the code to disconnect mlx5_core from QP logic and moves > qp.c to be under mlx5_ib responsibilities. > > Next series will convert mlx5_core to this new interface, so at this > point I tried to keep the amount of changes to the minimum. > > Thanks > > Leon Romanovsky (13): > net/mlx5: Provide simplified command interfaces > net/mlx5: Open-code create and destroy QP calls > net/mlx5: Remove empty QP and CQ events handlers > net/mlx5: Open-code modify QP in steering module > net/mlx5: Open-code modify QP in the FPGA module > net/mlx5: Open-code modify QP in the IPoIB module > net/mlx5: Remove extra indirection while storing QPN > net/mlx5: Replace hand written QP context struct with automatic > getters > net/mlx5: Remove Q counter low level helper APIs > RDMA/mlx5: Delete Q counter allocations command > net/mlx5: Delete not-used cmd header > RDMA/mlx5: Alphabetically sort build artifacts > net/mlx5: Move QP logic to mlx5_ib The whole series applied to the mlx5-next, please pull. Thanks