Re: [PATCH 2/2] RDMA/rxe: Rename rxe_atomic_reply to atomic_reply

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2022/7/6 15:38, Pearson, Robert B wrote:
> Generally over time I have been adding a rxe_ prefix to all searchable names static or non static.
> This avoids collisions with similar names in other drivers with e.g. ctags. I agree a unified naming
> Scheme is good but would like to see one with a common prefix for subroutine names.
Hi Bob,

I think it's hard to use unique name in all drivers. I saw that all 
functions called by different qp states don't use the rxe_ prefix in 
rxe_responders so just remove the rxe_ prefix. We can drop the patch if 
you don't agree with this change.

Best Regards,
Xiao Yang
> 
> Bob
> 
> -----Original Message-----
> From: Xiao Yang <yangx.jy@xxxxxxxxxxx>
> Sent: Tuesday, July 5, 2022 6:46 AM
> To: linux-rdma@xxxxxxxxxxxxxxx
> Cc: leon@xxxxxxxxxx; jgg@xxxxxxxx; rpearsonhpe@xxxxxxxxx; zyjzyj2000@xxxxxxxxx; Xiao Yang <yangx.jy@xxxxxxxxxxx>
> Subject: [PATCH 2/2] RDMA/rxe: Rename rxe_atomic_reply to atomic_reply
> 
> It's better to use the unified naming format.
> 
> Signed-off-by: Xiao Yang <yangx.jy@xxxxxxxxxxx>
> ---
>   drivers/infiniband/sw/rxe/rxe_resp.c | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/infiniband/sw/rxe/rxe_resp.c b/drivers/infiniband/sw/rxe/rxe_resp.c
> index 5536582b8fe4..265e46fe050f 100644
> --- a/drivers/infiniband/sw/rxe/rxe_resp.c
> +++ b/drivers/infiniband/sw/rxe/rxe_resp.c
> @@ -595,7 +595,7 @@ static struct resp_res *rxe_prepare_res(struct rxe_qp *qp,
>   /* Guarantee atomicity of atomic operations at the machine level. */  static DEFINE_SPINLOCK(atomic_ops_lock);
>   
> -static enum resp_states rxe_atomic_reply(struct rxe_qp *qp,
> +static enum resp_states atomic_reply(struct rxe_qp *qp,
>   					 struct rxe_pkt_info *pkt)
>   {
>   	u64 *vaddr;
> @@ -1333,7 +1333,7 @@ int rxe_responder(void *arg)
>   			state = read_reply(qp, pkt);
>   			break;
>   		case RESPST_ATOMIC_REPLY:
> -			state = rxe_atomic_reply(qp, pkt);
> +			state = atomic_reply(qp, pkt);
>   			break;
>   		case RESPST_ACKNOWLEDGE:
>   			state = acknowledge(qp, pkt);
> --
> 2.34.1
> 
> 
> 




[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Photo]     [Yosemite News]     [Yosemite Photos]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux