On Fri, Sep 28, 2007 at 11:51:41AM -0700, Andrew Morton wrote: > On Fri, 28 Sep 2007 10:19:21 -0700 Mark Gross <mgross@xxxxxxxxxxxxxxx> wrote: > > > On Thu, Sep 27, 2007 at 11:25:01PM -0700, Andrew Morton wrote: > > > On Wed, 26 Sep 2007 15:40:26 -0700 Mark Gross <mgross@xxxxxxxxxxxxxxx> wrote: > > > > > > > +#define QOS_RESERVED 0 > > > > +#define QOS_CPU_DMA_LATENCY 1 > > > > +#define QOS_NETWORK_LATENCY 2 > > > > +#define QOS_NETWORK_THROUGHPUT 3 > > > > + > > > > +#define QOS_NUM_CLASSES 4 > > > > +#define QOS_DEFAULT_VALUE -1 > > > > + > > > > +int qos_add_requirement(int qos, char *name, s32 value); > > > > +int qos_update_requirement(int qos, char *name, s32 new_value); > > > > +void qos_remove_requirement(int qos, char *name); > > > > > > It's a bit rude stealing the entire "qos" namespace like this - there are > > > many different forms of QoS, some already in-kernel. > > > > > > s/qos/pm_qos/g ? > > > > I suppose it is a bit inconiderate. I could grow to like pm_qos, > > performance_throttling_constraint_hint_infrastructure is a bit too > > wordy. > > > > I suppose I should use qospm as thats the way it was put up on that > > lesswatts.org web page. > > > > Would qospm be good enough? > > > > Don't think it matters a lot, but kernel naming tends to be big-endian (ie: > we have net_ratelimit, not ratelimit_net), so the major part (pm) would > come first under that scheme. this makes sense. pm_qos it is. --mgross _______________________________________________ linux-pm mailing list linux-pm@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/linux-pm