On Sat, 5 May 2007, Rafael J. Wysocki wrote: > > Yeah, whatever. You can fix the problem but it's ugly. Let's come up > > with a good way to do the 6 callbacks mentioned in some other thread > > earlier. > > This is the plan, but we need to do some preparations. > > For example, I think, we should introduce some consistent terminology, so that > we *always* know what we're talking about. A proposal: For suspend-to-RAM we already have suspend() and resume(). At the possible cost of introducing some confusion, I think it makes sense to keep those method names. For hibernation we need these: pre_snapshot() post_snapshot() pre_restore() post_restore() In addition we may want to have early/late variations on these (for use after interrupts have been disabled), which would lead to: pre_snapshot() pre_snapshot_late() post_snapshot_early() post_snapshot() pre_restore() pre_restore_late() post_restore_early() post_restore() Yes, it's a large list... But it seems to be necessary for providing all the information drivers will need. Alan Stern _______________________________________________ linux-pm mailing list linux-pm@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/linux-pm