On Fri, Jan 06, 2006 at 09:59:21AM +0100, Pavel Machek wrote: > On ??t 05-01-06 17:37:30, Patrick Mochel wrote: > > +static ssize_t pm_possible_states_show(struct device * d, > > + struct device_attribute * a, > > + char * buffer) > > +{ > > + struct pci_dev * dev = to_pci_dev(d); > > + char * s = buffer; > > + > > + s += sprintf(s, "d0"); > > + if (dev->poss_states[PCI_D1]) > > + s += sprintf(s, " d1"); > > + if (dev->poss_states[PCI_D2]) > > + s += sprintf(s, " d2"); > > + if (dev->poss_states[PCI_D3hot]) > > + s += sprintf(s, " d3"); > > Could we use same states as rest of code, i.e. "D2" instead of "d2" > and "D3hot" instead of "d3"? "D3hot" and "D3cold" most likely going to be removed and replaced with just "D3" in my next set of changes. Although this distinction is mentioned in the spec, d3cold cannot actually be specified. Rather, D3cold is entered when the parent bridge is powered off. Thanks, Adam