[RFC PATCH v1 0/9] PCI/portdrv: Squash into one file

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



The portdrv code is scattered across several files, which makes it a bit of
a hassle to browse.  Consolidate it all in a single file.

This is all pure code moves; no functional changes intended.  Well, there
is a function rename, but it shouldn't change any behavior.

---

Bjorn Helgaas (9):
      PCI/portdrv: Rename resume_iter() to prevent name collision
      PCI/portdrv: Squash pieces of portdrv_core.c into portdrv_pci.c
      PCI/portdrv: Squash PM-related code into portdrv_pci.c
      PCI/portdrv: Squash device removal code into portdrv_pci.c
      PCI/portdrv: Squash lookup interfaces into portdrv_pci.c
      PCI/portdrv: Squash service driver registration into portdrv_pci.c
      PCI/portdrv: Move private definitions to portdrv_pci.c
      PCI/portdrv: Clean up whitespace
      PCI/portdrv: Rename portdrv_pci.c to portdrv.c


 drivers/pci/pcie/Makefile       |    6 
 drivers/pci/pcie/portdrv.c      |  822 +++++++++++++++++++++++++++++++++++++++
 drivers/pci/pcie/portdrv.h      |   15 -
 drivers/pci/pcie/portdrv_core.c |  578 ---------------------------
 drivers/pci/pcie/portdrv_pci.c  |  261 ------------
 5 files changed, 824 insertions(+), 858 deletions(-)
 create mode 100644 drivers/pci/pcie/portdrv.c
 delete mode 100644 drivers/pci/pcie/portdrv_core.c
 delete mode 100644 drivers/pci/pcie/portdrv_pci.c



[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux