On Fri, Nov 10, 2017 at 07:52:30PM +0200, Andy Shevchenko wrote: > The current scanning code is really hard to understand because it calls > the same function in a loop where pass value is changed without any > comments explaining it: > > for (pass = 0; pass < 2; pass++) > for_each_pci_bridge(dev, bus) > max = pci_scan_bridge(bus, dev, max, pass); > > Unfamiliar reader cannot tell easily what is the purpose of this loop > without looking at internals of pci_scan_bridge(). > > In order to make this bit easier to understand, open-code the loop in > pci_scan_child_bus() and pci_hp_add_bridge() with added comments. > > No functional changes intended. > > Cc: Mika Westerberg <mika.westerberg@xxxxxxxxxxxxxxx> Reviewed-by: Mika Westerberg <mika.westerberg@xxxxxxxxxxxxxxx>