On Mon, Mar 13, 2017 at 9:14 AM, Gabriele Paoloni <gabriele.paoloni@xxxxxxxxxx> wrote: > About the name to use here from what you suggest we should use > "hisilicon,hip06-pcie-almost-ecam" and re-use it for hip07 SoC. > To be honest I would prefer it either as it is now or to modify the > driver as: > > diff --git a/drivers/pci/dwc/pcie-hisi.c b/drivers/pci/dwc/pcie-hisi.c > index 52f1e3f..7527b4c 100644 > --- a/drivers/pci/dwc/pcie-hisi.c > +++ b/drivers/pci/dwc/pcie-hisi.c > @@ -381,7 +381,11 @@ struct pci_ecam_ops hisi_pcie_platform_ops = { > > static const struct of_device_id hisi_pcie_almost_ecam_of_match[] = { > { > - .compatible = "hisilicon,pcie-almost-ecam", > + .compatible = "hisilicon,pcie-almost-ecam-hip06", Shouldn't that be "hisilicon,hip06-pcie-almost-ecam"? > + .data = (void *) &hisi_pcie_platform_ops, > + }, > + { > + .compatible = "hisilicon,pcie-almost-ecam-hip07", Shouldn't that be "hisilicon,hip07-pcie-almost-ecam"? > .data = (void *) &hisi_pcie_platform_ops, > }, Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds