- Add local "dev" pointers to reduce repetition of things like "&pdev->dev". - Remove platform drvdata because it appears unused (we called platform_set_drvdata() but not platform_get_drvdata()). - Removed an unnecessary platform_get_resource() return value check. - Rework TLB_CFG_DW0 and TLP_CFG_DW1 to make the code prettier. Nothing here should change the behavior of the driver. Changes from v1: I dropped the following patches because they were a lot of churn for questionable benefit: PCI: altera: Name private struct pointer "altera" consistently PCI: altera: Rename _altera_pcie_cfg_read() to altera_raw_cfg_read() PCI: altera: Rename CRA accessors PCI: altera: Swap order of altera_cra_writel() reg/val arguments --- Bjorn Helgaas (6): PCI: altera: Add local struct device pointers PCI: altera: Remove unused platform data PCI: altera: Remove redundant platform_get_resource() return value check PCI: altera: Rename altera_pcie_valid_config() to altera_pcie_valid_device() PCI: altera: Simplify TLB_CFG_DW0 usage PCI: altera: Simplify TLP_CFG_DW1 usage drivers/pci/host/pcie-altera.c | 77 +++++++++++++++++----------------------- 1 file changed, 33 insertions(+), 44 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html