Re: [PATCH 1/2] PCI: designware: Rename dw_pcie_valid_config() to dw_pcie_valid_device()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Aug 24, 2016 at 3:40 AM, Bjorn Helgaas <bhelgaas@xxxxxxxxxx> wrote:
> Rename dw_pcie_valid_config() to dw_pcie_valid_device() and use the result
> directly as a boolean value instead of testing against 0.
>
> No functional change intended; for readability only.
>
> Signed-off-by: Bjorn Helgaas <bhelgaas@xxxxxxxxxx>

Acked-by: Pratyush Anand <pratyush.anand@xxxxxxxxx>

> ---
>  drivers/pci/host/pcie-designware.c |    8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/pci/host/pcie-designware.c b/drivers/pci/host/pcie-designware.c
> index 12afce1..d09f376 100644
> --- a/drivers/pci/host/pcie-designware.c
> +++ b/drivers/pci/host/pcie-designware.c
> @@ -657,8 +657,8 @@ static int dw_pcie_wr_other_conf(struct pcie_port *pp, struct pci_bus *bus,
>         return ret;
>  }
>
> -static int dw_pcie_valid_config(struct pcie_port *pp,
> -                               struct pci_bus *bus, int dev)
> +static int dw_pcie_valid_device(struct pcie_port *pp, struct pci_bus *bus,
> +                               int dev)
>  {
>         /* If there is no link, then there is no device */
>         if (bus->number != pp->root_bus_nr) {
> @@ -685,7 +685,7 @@ static int dw_pcie_rd_conf(struct pci_bus *bus, u32 devfn, int where,
>  {
>         struct pcie_port *pp = bus->sysdata;
>
> -       if (dw_pcie_valid_config(pp, bus, PCI_SLOT(devfn)) == 0) {
> +       if (!dw_pcie_valid_device(pp, bus, PCI_SLOT(devfn))) {
>                 *val = 0xffffffff;
>                 return PCIBIOS_DEVICE_NOT_FOUND;
>         }
> @@ -701,7 +701,7 @@ static int dw_pcie_wr_conf(struct pci_bus *bus, u32 devfn,
>  {
>         struct pcie_port *pp = bus->sysdata;
>
> -       if (dw_pcie_valid_config(pp, bus, PCI_SLOT(devfn)) == 0)
> +       if (!dw_pcie_valid_device(pp, bus, PCI_SLOT(devfn)))
>                 return PCIBIOS_DEVICE_NOT_FOUND;
>
>         if (bus->number == pp->root_bus_nr)
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-pci" in
> the body of a message to majordomo@xxxxxxxxxxxxxxx
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux