[PATCH v4 0/6] PCI: Support multiple DMA aliases

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is a revision of Jacek's v3 posting:
http://lkml.kernel.org/r/1454152012-46337-1-git-send-email-jacek.lawrynowicz@xxxxxxxxx

The changes from v3 are:

  - Split into smaller patches for reviewability
  - Move printk when adding DMA alias
  - Change dma_alias_is_enabled() interface to take two pci_devs
  - Rename dma_alias_is_enabled() to indicate PCI context

The only remaining thing I want to sort out is the dma_alias_is_enabled()
vs pci_for_each_dma_alias() question Alex raised.  I'll respond to the
relevant part of the patch in this series with my specific questions.

---

Bjorn Helgaas (1):
      PCI: Rename dma_alias_is_enabled() to pci_devs_are_dma_aliases()

Jacek Lawrynowicz (5):
      PCI: Add pci_add_dma_alias() to abstract implementation
      PCI: Move informational printk to pci_add_dma_alias()
      PCI: Add support for multiple DMA aliases
      pci: Add DMA alias quirk for mic_x200_dma
      PCI: Squash pci_dev_flags to remove holes


 drivers/iommu/iommu.c |   18 +++++++++++-------
 drivers/pci/pci.c     |   23 +++++++++++++++++++++++
 drivers/pci/pci.h     |    2 ++
 drivers/pci/probe.c   |    1 +
 drivers/pci/quirks.c  |   34 +++++++++++++++++++---------------
 drivers/pci/search.c  |   14 +++++++++-----
 include/linux/pci.h   |   12 +++++-------
 7 files changed, 70 insertions(+), 34 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux