Dear Jingoo Han, On Wed, 09 Oct 2013 10:33:30 +0900, Jingoo Han wrote: > ./drivers/pci/host/pci-mvebu.c > @@ -243,14 +243,7 @@ static int mvebu_pcie_hw_rd_conf(struct mvebu_pcie_port *port, > writel(PCIE_CONF_ADDR(bus->number, devfn, where), > port->base + PCIE_CONF_ADDR_OFF); > > - *val = readl(port->base + PCIE_CONF_DATA_OFF); > - > - if (size == 1) > - *val = (*val >> (8 * (where & 3))) & 0xff; > - else if (size == 2) > - *val = (*val >> (8 * (where & 3))) & 0xffff; > - > - return PCIBIOS_SUCCESSFUL; > + return cfg_read(port->base + PCIE_CONF_DATA_OFF, where, size, val); > } The cfg_read() name looks too generic to me to be globally exported in the kernel, but provided a more specific name is used, I'm fine with using that in the PCIe mvebu driver. Thanks! Thomas -- Thomas Petazzoni, Free Electrons Embedded Linux, Kernel and Android engineering http://free-electrons.com -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html