On Wed, Nov 3, 2021 at 9:31 AM Bjorn Helgaas <helgaas@xxxxxxxxxx> wrote: > > [+to Mauro, author of code being changed, > Rob for "of_pci_get_devfn()" naming question] > > On Wed, Nov 03, 2021 at 02:25:18AM -0400, Wan Jiabing wrote: > > Fix following coccicheck warning: > > ./drivers/pci/controller/dwc/pcie-kirin.c:414:2-34: WARNING: Function > > for_each_available_child_of_node should have of_node_put() before return. > > > > Early exits from for_each_available_child_of_node should decrement the > > node reference counter. Replace return by goto here. > > > > Signed-off-by: Wan Jiabing <wanjiabing@xxxxxxxx> > > --- > > drivers/pci/controller/dwc/pcie-kirin.c | 3 ++- > > 1 file changed, 2 insertions(+), 1 deletion(-) > > > > diff --git a/drivers/pci/controller/dwc/pcie-kirin.c b/drivers/pci/controller/dwc/pcie-kirin.c > > index 06017e826832..23a2c076ce53 100644 > > --- a/drivers/pci/controller/dwc/pcie-kirin.c > > +++ b/drivers/pci/controller/dwc/pcie-kirin.c > > @@ -422,7 +422,8 @@ static int kirin_pcie_parse_port(struct kirin_pcie *pcie, > > pcie->num_slots++; > > if (pcie->num_slots > MAX_PCI_SLOTS) { > > dev_err(dev, "Too many PCI slots!\n"); > > - return -EINVAL; > > + ret = -EINVAL; > > + goto put_node; > > } > > > > ret = of_pci_get_devfn(child); > > This is a change to the code added here: > https://git.kernel.org/pub/scm/linux/kernel/git/helgaas/pci.git/commit/?id=31bd24f0cfe0 > > This fix looks right to me; all the other early exits from the inner > loop drop the "child" reference. > > But this is a nested loop and the *outer* loop also increments > refcounts, and I don't see that outer loop reference on "parent" being > dropped at all: > > for_each_available_child_of_node(node, parent) { > for_each_available_child_of_node(parent, child) { > ... > if (error) > goto put_node; > } > } > > put_node: > of_node_put(child); Indeed. There should be a put on the parent. This whole function is less than ideal as it assumes the board has 2 levels of PCI nodes. This might be another (like brcmstb thread) place to use .add_bus(). But that's a problem for another day. > The "of_pci_get_devfn()" immediately after is unrelated, but possibly > a confusing name. "Get" often suggests a reference count being > increased, but that's not the case with of_pci_get_devfn(). I guess you have to know that only nodes are refcounted and property functions never are. There's also of_pci_get_max_link_speed() and of_get_pci_domain_nr(). Rob