On Wed, 2009-07-01 at 12:33 -0700, Yinghai Lu wrote: > --- linux-2.6.orig/include/linux/kernel.h > +++ linux-2.6/include/linux/kernel.h [] > #define roundup(x, y) ((((x) + ((y) - 1)) / (y)) * (y)) > +#define rounddown(x, y) (((x) / (y)) * (y)) [] > +#define round_up(x,y) ((((x)-1) | __round_mask(x,y))+1) > +#define round_down(x,y) ((x) & ~__round_mask(x,y)) Isn't this just asking for trouble? How about a better name? Maybe masked_roundup, or roundup_ala_zorro... -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html