Linus Torvalds wrote: > > On Fri, 17 Apr 2009, Yinghai Lu wrote: >> it turns that we need to reget res->name because dev->dev.kobj name is changed >> after device_add. > > Can we not make the rule be that the name should just be set before? > > IOW, there is something else broken, I think. Rather than put this ugly > band-aid, why now make sure that whoever had that broken name fixes it? > driver core guys are enforcing to use dev_name(device) instead of referring it. for pci code: via acpi_pci_root_driver.ops.add (aka acpi_pci_root_add) ==> pci_acpi_scan_root is used to scan pci bus/device, and at the same we read the resource for pci_dev at this point still need to use bus->devices to go over all pci_devices if needed. in the pci_read_bases, we have res->name = pci_name(pci_dev); pci_name is calling dev_name. later via acpi_pci_root_driver.ops.start (aka acpi_pci_root_start) ==> pci_bus_add_device to add all pci_dev in kobj tree. pci_bus_add_device will call device_add. actually in device_add /* first, register with generic layer. */ error = kobject_add(&dev->kobj, dev->kobj.parent, "%s", dev_name(dev)); if (error) goto Error; will get one new name for that kobj, old name is freed. Will try to make kobject_add more smart to reuse the old one. YH -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html