On Wed, Feb 29, 2012 at 12:43 PM, Kevin Hilman <khilman@xxxxxx> wrote: > Robert Lee <rob.lee@xxxxxxxxxx> writes: > >> Make necessary changes to implement time keeping and irq enabling >> in the core cpuidle code. This will allow the removal of these >> functionalities from various platform cpuidle implementations whose >> timekeeping and irq enabling follows the form in this common code. >> >> Signed-off-by: Robert Lee <rob.lee@xxxxxxxxxx> >> --- >> arch/arm/include/asm/cpuidle.h | 14 ++++++ >> drivers/cpuidle/cpuidle.c | 90 ++++++++++++++++++++++++++++++++-------- >> include/linux/cpuidle.h | 13 ++++++ >> 3 files changed, 99 insertions(+), 18 deletions(-) >> create mode 100644 arch/arm/include/asm/cpuidle.h >> >> diff --git a/arch/arm/include/asm/cpuidle.h b/arch/arm/include/asm/cpuidle.h >> new file mode 100644 >> index 0000000..1d2075b >> --- /dev/null >> +++ b/arch/arm/include/asm/cpuidle.h >> @@ -0,0 +1,14 @@ >> +#ifndef __ASM_ARM_CPUIDLE_H >> +#define __ASM_ARM_CPUIDLE_H >> + >> +/* Common ARM WFI state */ >> +#define CPUIDLE_ARM_WFI_STATE {\ >> + .enter = cpuidle_simple_enter,\ >> + .exit_latency = 1,\ >> + .target_residency = 1,\ >> + .flags = CPUIDLE_FLAG_TIME_VALID,\ >> + .name = "WFI",\ >> + .desc = "ARM core clock gating (WFI)",\ >> +} > > nit: just name this ARM WFI. Clock gating is platform specific, and > "core" has platform-specific meanings, so in order to keep this truly > generic, I think hat ARM WFI is the best name. > Agree. I'll make that change. > Kevin > > -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html