* Peter Ujfalusi <peter.ujfalusi@xxxxxx> [110607 17:14]: > Reduce the amount of duplicated code by moving the common > configuration for twl4030/5030/tpsxx to the pmic-common file. > Use the omap3_pmic_config function from board files to > properly configure the PMIC with the common fields. ... > --- a/arch/arm/mach-omap2/pmic-common.h > +++ b/arch/arm/mach-omap2/pmic-common.h > @@ -2,6 +2,9 @@ > #define __OMAP_PMIC_COMMON__ > > #define TWL_COMMON_PDATA_USB (1 << 0) > +#define TWL_COMMON_PDATA_BCI (1 << 1) > +#define TWL_COMMON_PDATA_MADC (1 << 2) > +#define TWL_COMMON_PDATA_CODEC (1 << 3) This is looking good, thanks for cleaning up the twl bloat in board-*.c files :) Maybe already define TWL_COMMON_PDATA_AUDIO here so you can drop most of patch 7/12? If you need both then you can temporarily have: #define TWL_COMMON_PDATA_CODEC TWL_COMMON_PDATA_AUDIO Regards, Tony -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html