Re: [PATCHv3 01/22] OMAP3: PM: Adding hwmod data for Smartreflex

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Thara Gopinath <thara@xxxxxx> writes:

> This patch adds the hwmod strucutres and other hwmod data for
> OMAP3 Smartreflex IP's.

Should also comment about the additional data used in dev_attr as well.

> Signed-off-by: Thara Gopinath <thara@xxxxxx>
> ---
>  arch/arm/mach-omap2/omap_hwmod_3xxx_data.c |  135 ++++++++++++++++++++++++++++
>  arch/arm/mach-omap2/smartreflex.h          |   33 +++++++
>  2 files changed, 168 insertions(+), 0 deletions(-)
>

[...]

> diff --git a/arch/arm/mach-omap2/smartreflex.h b/arch/arm/mach-omap2/smartreflex.h
> index 2a0e823..d239eb2 100644
> --- a/arch/arm/mach-omap2/smartreflex.h
> +++ b/arch/arm/mach-omap2/smartreflex.h
> @@ -237,6 +237,39 @@ extern u32 current_vdd2_opp;
>  #define SR_TESTING_NVALUES 	0
>  #endif
>  
> +/**
> + * omap_smartreflex_dev_data - Smartreflex device specific data
> + *
> + * @volts_supported	: Number of distinct voltages possible for the VDD
> + *			  associated with this smartreflex module.
> + * @efuse_sr_control	: The regisrter offset of control_fuse_sr efuse
> + *			  register from which sennenable and senpenable values
> + *			  are obtained.
> + * @sennenable_shift	: The shift in the control_fuse_sr register for
> + *			  obtaining the sennenable value for this smartreflex
> + *			  module.
> + * @senpenable_shift	: The shift in the control_fuse_sr register for
> + *			  obtaining the senpenable value for this smartreflex
> + *			  module.
> + * @efuse_nvalues_offs	: Array of efuse offsets from which ntarget values can
> + *			  be retrieved. Number of efuse offsets in this arrray
> + *			  is equal to the volts_supported value ie one efuse
> + *			  register per supported voltage.
> + * @test_sennenable	: SENNENABLE test value
> + * @test_senpenable	: SENPENABLE test value.
> + * @test_nvalues	: Array of test ntarget values.
> + */
> +struct omap_smartreflex_dev_data {

Minor nit here, but this could be named omap_sr_dev_data to
keep the name shorter and avoid some of the wrapping that has to
be done in other code because of this.

Kevin
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Arm (vger)]     [ARM Kernel]     [ARM MSM]     [Linux Tegra]     [Linux WPAN Networking]     [Linux Wireless Networking]     [Maemo Users]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux