Please let me know the mail thread mentioning this rule has been removed. I still see it under CodingStyle as the preferred approach. Anyway, I have am sending a second version of this patch removing this ugly indenting. Best regards, Armando. -----Original Message----- From: Felipe Contreras [mailto:felipe.contreras@xxxxxxxxx] Sent: Saturday, April 17, 2010 2:10 PM To: Uribe de Leon, Armando Cc: linux-omap@xxxxxxxxxxxxxxx; hiroshi.DOYU@xxxxxxxxx; ameya.palande@xxxxxxxxx; felipe.contreras@xxxxxxxxx Subject: Re: [PATCH 2/5] DSPBRIDGE: Remove checkpatch errors: 80 char lines On Sat, Apr 17, 2010 at 9:44 PM, Uribe de Leon, Armando <x0095078@xxxxxx> wrote: > From 27145cb2f0aa004a9c4159ad094c0ae60f75a3b3 Mon Sep 17 00:00:00 2001 > From: Armando Uribe De Leon <x0095078@xxxxxx> > Date: Thu, 8 Apr 2010 15:20:09 -0500 > Subject: [PATCH 2/5] DSPBRIDGE: Remove checkpatch errors: 80 char lines > > This patch removes checkptach errors regarding with lines exceeded 80 chatacters. Those are warnings, not errors, and I believe this 80 char lines guideline has been removed. > - if (DSP_FAILED(status)) { > - if (status == DSP_ETIMEOUT) { > - status = (*intf_fxns->pfn_msg_put) > - (hnode->msg_queue_obj, &killmsg, > - hnode->utimeout); > - if (DSP_SUCCEEDED(status)) { > - status = sync_wait_on_event > - (hnode->sync_done, > - kill_time_out / 2); > - if (DSP_FAILED(status)) { > - /* Here it goes the part > - * of the simulation of > - * the DSP exception */ > - dev_get_deh_mgr > - (hnode_mgr->hdev_obj, > - &hdeh_mgr); > - if (hdeh_mgr) { > - (*intf_fxns-> > - pfn_deh_notify) > - (hdeh_mgr, > - DSP_SYSERROR, > - DSP_EXCEPTIONABORT); > - status = > - DSP_EFAIL; > - } > - } else > - status = DSP_SOK; > - } > - } else > - status = DSP_EFAIL; > - } else /* Convert SYNC status to DSP status */ > - status = DSP_SOK; > + if (status == DSP_ETIMEOUT) { > + status = (*intf_fxns->pfn_msg_put) > + (hnode->msg_queue_obj, &killmsg, > + hnode->utimeout); > + if (DSP_SUCCEEDED(status)) { > + status = sync_wait_on_event > + (hnode->sync_done, > + kill_time_out / 2); > + if (DSP_FAILED(status)) { > + /* Here it goes the part > + * of the simulation of > + * the DSP exception */ > + dev_get_deh_mgr > + (hnode_mgr->hdev_obj, > + &hdeh_mgr); > + if (hdeh_mgr) { > + (*intf_fxns-> > + pfn_deh_notify) > + (hdeh_mgr, > + DSP_SYSERROR, > + DSP_EXCEPTIONABORT); > + status = DSP_EFAIL; > + } > + } else > + status = DSP_SOK; > + } > + } This looks very ugly. Wouldn't it make sense to split the function to avoid this huge indenting? -- Felipe Contreras -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html