Hiremath, Vaibhav wrote:
-----Original Message-----
From: linux-omap-owner@xxxxxxxxxxxxxxx [mailto:linux-omap-
owner@xxxxxxxxxxxxxxx] On Behalf Of Stanley.Miao
Sent: Tuesday, April 13, 2010 3:02 PM
To: linux-omap@xxxxxxxxxxxxxxx
Cc: tony@xxxxxxxxxxx
Subject: [PATCH 03/11] AM3517: rename the i2c boardinfo to make it more
readable
There are three i3c buses on am3517,
[Hiremath, Vaibhav] Please correct the typo here.
I will correct it in V2.
Thanks.
now rename these three boardinfo
structure name to am3517evm_i2c1_boardinfo, am3517evm_i2c2_boardinfo,
and am3517evm_i2c3_boardinfo, to make it more readable.
<snip>
}
@@ -425,8 +425,8 @@ static void __init am3517_evm_init(void)
/* RTC - S35390A */
am3517_evm_rtc_init();
- i2c_register_board_info(1, am3517evm_i2c_boardinfo,
- ARRAY_SIZE(am3517evm_i2c_boardinfo));
+ i2c_register_board_info(1, am3517evm_i2c1_boardinfo,
+ ARRAY_SIZE(am3517evm_i2c1_boardinfo));
}
[Hiremath, Vaibhav] personally I like the idea of specifying explicitly the I2C instance here which you did, I have seen other board files using slave device name while defining the I2C board info. I am not sure about whether we have any standard thing to follow here.
Let's take opinion from other folks here; if they are ok with this approach then I think we can merge this patch.
There are many slave devices on each i2c bus.
I2C1: S35390, TPS65023, TSC2004, four INA219.
I2C2: TCA6416PW, two TLV320AIC23
I2C3: two TCA6416PW, TLV320AIC23, TVP5146.
So we can't name the i2c board files with the slave device names
Stanley.
Thanks,
Vaibhav
static void __init am3517_evm_map_io(void)
--
1.5.4.3
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html