Re: [PATCH 04/14] mux: mmio: Add resume support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hello Peter,

Thanks for the review.

On 1/15/24 23:31, Peter Rosin wrote:
> Hi!
> 
> 2024-01-15 at 17:14, Thomas Richard wrote:
>> From: Théo Lebrun <theo.lebrun@xxxxxxxxxxx>
>>
>> Implement resume support
> 
> What Andy said, and please don't omit punctuation. Try to make it a
> pleasure to read your patches!

Yes my commit message needs to be more verbose, sorry.

> 
>>
>> Signed-off-by: Théo Lebrun <theo.lebrun@xxxxxxxxxxx>
>> Signed-off-by: Thomas Richard <thomas.richard@xxxxxxxxxxx>
>> ---
>>  drivers/mux/mmio.c | 34 ++++++++++++++++++++++++++++++++++
>>  1 file changed, 34 insertions(+)
>>
>> diff --git a/drivers/mux/mmio.c b/drivers/mux/mmio.c
>> index fd1d121a584b..ab4ef195fc0d 100644
>> --- a/drivers/mux/mmio.c
>> +++ b/drivers/mux/mmio.c
>> @@ -125,13 +125,47 @@ static int mux_mmio_probe(struct platform_device *pdev)
>>  
>>  	mux_chip->ops = &mux_mmio_ops;
>>  
>> +	dev_set_drvdata(dev, mux_chip);
>> +
>>  	return devm_mux_chip_register(dev, mux_chip);
>>  }
>>  
>> +#ifdef CONFIG_PM
>> +static int mux_mmio_resume_noirq(struct device *dev)
>> +{
>> +	struct mux_chip *mux_chip = dev_get_drvdata(dev);
>> +	int global_ret = 0;
>> +	unsigned int i;
>> +
>> +	for (i = 0; i < mux_chip->controllers; i++) {
>> +		struct mux_control *mux = &mux_chip->mux[i];
>> +		int val = mux->cached_state;
> 
> You are not supposed to look at (or change) cached_state outside the
> mux core.
> 
>> +		int ret;
>> +
>> +		if (val == MUX_IDLE_AS_IS)
> 
> The cached_state can never be MUX_IDLE_AS_IS. Sure, it happens to have
> the same actual value as the correct MUX_CACHE_UNKNOWN, but abusing
> that is all kinds of wrong.
> 
>> +			continue;
>> +
>> +		ret = mux_mmio_set(mux, val);
>> +		if (ret) {
> 
> If mux_mmio_set() fails, cached_state ends up wrong as it should be set
> to MUX_CACHE_UNKNOWN on failure. Low-level stuff like this needs to be
> done by the mux core, or things becomes a maintenance hazard...
> 
> So, the meat of this function belongs in the mux core since none of
> it looks mmio specific. It could probably be named mux_chip_resume()
> or something such. That makes it simple to use the correct constant,
> and the mux_control_set() helper makes it easy to get the handling of
> cached_state right.
> 

Thanks for the explanations.

So I created a mux_chip_resume function in the mux core.
This function restores each mux using mux_control_set.
The restored state is the cached state.
The muxes with a MUX_CACHE_UNKNOWN cache state are ignored.

So this patch will be splitted, one patch for the core, one for the mmio
driver.

Regards,

-- 
Thomas Richard, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com





[Index of Archives]     [Linux Arm (vger)]     [ARM Kernel]     [ARM MSM]     [Linux Tegra]     [Linux WPAN Networking]     [Linux Wireless Networking]     [Maemo Users]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux