On Mon, May 17, 2021 at 05:41:17PM +0200, Luca Ceresoli wrote: > This is an series of mixed improvements to the DRA7 PCI controller driver: > allow building as a loadabel module, allow to get and enable a clock and a > small cleanup. > > Luca > > Luca Ceresoli (5): > PCI: dwc: export more symbols to allow modular drivers > PCI: dwc: pci-dra7xx: make it a kernel module > PCI: dwc: pci-dra7xx: allow to build as a loadable module > PCI: dwc: pci-dra7xx: remove unused include > PCI: dwc: pci-dra7xx: get an optional clock This driver has a poor record of subject lines: PCI: pci-dra7xx: Prepare for deferred probe with module_platform_driver PCI: dwc: Move dw_pcie_setup_rc() to DWC common code PCI: dwc/dra7xx: Use the common MSI irq_chip PCI: dwc: pci-dra7xx: Fix runtime PM imbalance on error The "PCI: dwc:" ones are fine -- they apply to the shared dwc core, not specifically to dra7xx. The driver-specific ones: PCI: pci-dra7xx: PCI: dwc/dra7xx: PCI: dwc: pci-dra7xx: are redundant and waste space. There's no need to mention "dwc" for dra7xx-specific things, and no need to mention "PCI" twice. We should use the "PCI: dra7xx:" prefix for things specific to this driver. The rest of the subject line should start with a capital letter. The subject line should contain specific information when practical. For example, PCI: dwc: Export dw_pcie_link_up(), dw_pcie_ep_reset_bar() for modular drivers PCI: dra7xx: Allow building as module PCI: dra7xx: Remove unused linux/init.h include PCI: dra7xx: Get optional external clock I would squash 2/5 and 3/5, similar to a98d2187efd9 ("PCI: meson: Build as module by default") and 526a76991b7b ("PCI: aardvark: Implement driver 'remove' function and allow to build it as module"). > drivers/pci/controller/dwc/Kconfig | 6 +++--- > drivers/pci/controller/dwc/pci-dra7xx.c | 21 +++++++++++++++++-- > .../pci/controller/dwc/pcie-designware-ep.c | 1 + > drivers/pci/controller/dwc/pcie-designware.c | 1 + > 4 files changed, 24 insertions(+), 5 deletions(-) > > -- > 2.25.1 >