2018-07-19 11:09 GMT+02:00 Dan Carpenter <dan.carpenter@xxxxxxxxxx>: > > Maybe it would be simpler as three separate functions: > > int of_eth_get_mac_address() <- rename existing function to this > int nvmem_eth_get_mac_address() <- patch 2 > int mtd_eth_nvmem_get_mac_address() patch 3 > > int ret; > > ret = of_eth_get_mac_address(dev, mac_addr); > if (!ret) > return 0; > ret = nvmem_eth_get_mac_address(dev, mac_addr); > if (ret == -EPROBEDEFER) > return ret; > if (!ret) > return 0; > ret = mtd_eth_nvmem_get_mac_address(dev, mac_addr); > if (!ret) > return 0; > > return -ENODEV; > > regards, > dan carpenter It looks simpler as long as you don't add all the new routines resulting from this approach. I've just tried to quickly implement this solution and it resulted in much bigger and duplicated code (checking the validity of mac_addr, copying it etc.). I would prefer the current approach and would like to read someone else's opinion on that. Thanks, Bart > -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html