Hi Girish, On Thu, Jul 3, 2008 at 3:01 PM, Girish S G <girishsg@xxxxxx> wrote: > ----- Original Message ----- From: "Trilok Soni" <soni.trilok@xxxxxxxxx> > >>> +static struct omap_irda_config irda_data = { >>> + .transceiver_cap = IR_SIRMODE | IR_MIRMODE | IR_FIRMODE, >>> + .transceiver_mode = transceiver_mode, >>> + .select_irda = select_irda, >> >> >> Please rename this hooks to 3430sdp_transceiver_mode and >> 3430sdp_select_irda. Check board_h4.c for example. >> > I think it can be made irda_transceiver_mode/irda_select. And, as this is > in 3430 board file, prefixing it with 3430sdp serves no purpose i guess. > I am leaving this decision to you. I am more interested in moving the platform data members below as platform resource and also changing the same for all the boards :) > >>> + .rx_channel = OMAP24XX_DMA_UART3_RX, >>> + .tx_channel = OMAP24XX_DMA_UART3_TX, >>> + .dest_start = OMAP_UART3_BASE, >>> + .src_start = OMAP_UART3_BASE, >>> + .tx_trigger = OMAP24XX_DMA_UART3_TX, >>> + .rx_trigger = OMAP24XX_DMA_UART3_RX, >>> +}; >> >> Actually rx_channel to rx_trigger are not platform data and it is long >> pending cleanup. It would great if we can convert this to >> platform_resource, as it is chip specific not board specific. >> > Yes, I agree. > > > -girish > -- ---Trilok Soni http://triloksoni.wordpress.com -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html