On Fri, Jun 06, 2008 at 06:30:38PM -0700, Tony Lindgren wrote: > @@ -431,8 +474,8 @@ struct omap_dma_channel_params { > > extern void omap_set_dma_priority(int lch, int dst_port, int priority); > extern int omap_request_dma(int dev_id, const char *dev_name, > - void (* callback)(int lch, u16 ch_status, void *data), > - void *data, int *dma_ch); > + void (*callback)(int lch, u16 ch_status, > + void *data), void *data, int *dma_ch); This is an example where checkpatch is not entirely correct - wrapping the 'callback' type makes it less readable. Just let it flow over column 80, or maybe use: void (*callback)(int, u16, void *), since all we actually need there is the type of the callback. -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html