On Fri, 2008-01-18 at 00:56 -0600, Felipe Balbi wrote: > > On Thu, 17 Jan 2008 21:50:36 -0800, Daniel Walker <dwalker@xxxxxxxxxx> > wrote: > > The audio_pwr_sem conforms to the new mutex API. This patch converts > > the semaphore to the new API along with all the locking locations. > > > > I also changed the name to reflect the new type. > > > > Signed-off-by: Daniel Walker <dwalker@xxxxxxxxxx> > > > > --- > > arch/arm/mach-omap1/board-nokia770.c | 17 +++++++++-------- > > 1 file changed, 9 insertions(+), 8 deletions(-) > > > > Index: linux-2.6.23/arch/arm/mach-omap1/board-nokia770.c > > =================================================================== > > --- linux-2.6.23.orig/arch/arm/mach-omap1/board-nokia770.c > > +++ linux-2.6.23/arch/arm/mach-omap1/board-nokia770.c > > @@ -18,6 +18,7 @@ > > #include <linux/spi/ads7846.h> > > #include <linux/workqueue.h> > > #include <linux/delay.h> > > +#include <linux/mutex.h> > > > > #include <asm/hardware.h> > > #include <asm/mach-types.h> > > @@ -204,7 +205,7 @@ static struct omap_board_config_kernel n > > #define AMPLIFIER_CTRL_GPIO 58 > > > > static struct clk *dspxor_ck; > > -static DECLARE_MUTEX(audio_pwr_sem); > > +static DEFINE_MUTEX(audio_pwr_mutex); > > /* > > * audio_pwr_state > > * > +--+-------------------------+---------------------------------------+ > > @@ -220,7 +221,7 @@ static DECLARE_MUTEX(audio_pwr_sem); > > static int audio_pwr_state = -1; > > > > /* > > - * audio_pwr_up / down should be called under audio_pwr_sem > > + * audio_pwr_up / down should be called under audio_pwr_mutex > > stupid comment but it's not down anylonger, it's mutex_unlock. I don't think it's referring to the old semaphore operations .. It saying the audio_pwr_up should be called with the lock held .. It's a function to activate audio I think .. Daniel - To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html