[PATCH v2 0/5] nfs: consolidate rename code into one set of functions

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Summary of changes:

v2: remove -ERESTARTSYS error handling in nfs_rename
    hardcode isdir value in fsnotify_nameremove call for sillyrenames
     
As Trond pointed out recently, it makes little sense to maintain two
separate sets of functions for handling RENAMEs.

This patchset converts nfs_rename to use the asynchronous RENAME
infrastructure that is already in place for sillyrenames. It also
does some cleanup to remove some minor layering violations, and
adds a patch to make the sillyrename code emit a fsnotify_nameremove
when a sillyrename succeeds.

I've lightly tested this set and it seems to do the right thing,
but it obviously could stand some time in linux-next.

Jeff Layton (5):
  nfs: abstract out code needed to complete a sillyrename
  nfs: make nfs_async_rename non-static
  nfs: convert nfs_rename to use async_rename infrastructure
  nfs: remove synchronous rename code
  nfs: emit a fsnotify_nameremove call in sillyrename codepath

 fs/nfs/dir.c            | 13 +++++++++++--
 fs/nfs/internal.h       |  7 +++++++
 fs/nfs/nfs3proc.c       | 36 ------------------------------------
 fs/nfs/nfs4proc.c       | 44 --------------------------------------------
 fs/nfs/proc.c           | 25 -------------------------
 fs/nfs/unlink.c         | 35 ++++++++++++++++++++++++++++++-----
 include/linux/nfs_fs.h  |  1 -
 include/linux/nfs_xdr.h |  3 +--
 8 files changed, 49 insertions(+), 115 deletions(-)

-- 
1.8.5.3

--
To unsubscribe from this list: send the line "unsubscribe linux-nfs" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Filesystem Development]     [Linux USB Development]     [Linux Media Development]     [Video for Linux]     [Linux NILFS]     [Linux Audio Users]     [Yosemite Info]     [Linux SCSI]

  Powered by Linux