Hi all, Today's linux-next merge of the tip tree got a conflict in drivers/hwmon/coretemp.c between commit 3c1aae21b09d ("hwmon: struct x86_cpu_id arrays can be __initconst") from the jdelvare-hwmon tree and commit 3bac8715443f ("x86, cpufeature: Rename X86_FEATURE_DTS to X86_FEATURE_DTHERM") from the tip tree. Just context changes. I fixed it up (see below) and can carry the fix as necessary. P.S. that tip tree commit has no Signed-off-by line at all :-( -- Cheers, Stephen Rothwell sfr@xxxxxxxxxxxxxxxx diff --cc drivers/hwmon/coretemp.c index b405781,637c51c..0000000 --- a/drivers/hwmon/coretemp.c +++ b/drivers/hwmon/coretemp.c @@@ -793,8 -793,8 +793,8 @@@ static struct notifier_block coretemp_c .notifier_call = coretemp_cpu_callback, }; -static const struct x86_cpu_id coretemp_ids[] = { +static const struct x86_cpu_id __initconst coretemp_ids[] = { - { X86_VENDOR_INTEL, X86_FAMILY_ANY, X86_MODEL_ANY, X86_FEATURE_DTS }, + { X86_VENDOR_INTEL, X86_FAMILY_ANY, X86_MODEL_ANY, X86_FEATURE_DTHERM }, {} }; MODULE_DEVICE_TABLE(x86cpu, coretemp_ids);
Attachment:
pgpEuU0SOHU8A.pgp
Description: PGP signature