[PATCH v2 0/6] mtd: rawnand: atmel: Convert the driver to exec_op()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hello,

This v2 splits changes to make the diff more readable and fixes a bug
reported by Tudor (thanks for testing/helping me debug the issue BTW).
Note that the patch propagating the CS information to sub operations
has been dropped since the new version no longer depends on it, but
will be posted as part of another series where it's needed (the
cafe_nand conversion).

Regards,

Boris

Boris Brezillon (6):
  mtd: rawnand: atmel: Enable the NFC controller at probe time
  mtd: rawnand: atmel: Drop redundant nand_read_page_op()
  mtd: rawnand: atmel: Use nand_{write,read}_data_op()
  mtd: rawnand: atmel: Use nand_prog_page_end_op()
  mtd: rawnand: atmel: Convert the driver to exec_op()
  mtd: rawnand: atmel: Get rid of the legacy interface implementation

 drivers/mtd/nand/raw/atmel/nand-controller.c | 464 +++++++++++--------
 1 file changed, 258 insertions(+), 206 deletions(-)

-- 
2.25.3


______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/



[Index of Archives]     [LARTC]     [Bugtraq]     [Yosemite Forum]     [Photo]

  Powered by Linux