Hello, Miquel Raynal <miquel.raynal@xxxxxxxxxxx> wrote on Thu, 17 Jan 2019 16:29:28 +0100: > __mtd_del_partition() is a helper that must be called after the > partition lock has ben taken. As there are already a few similar names > (mtd_del_partitions(), del_mtd_partitions(), __mtd_del_partitions()), > make this clear by renaming the helper mtd_del_partition_locked(). > > Signed-off-by: Miquel Raynal <miquel.raynal@xxxxxxxxxxx> > --- And here is the changelog: Changes since v2: ================= * Added a patch to rename __del_mtd_partition() into del_mtd_partition_locked(). * Fixed bugs in the implementation. * Added a union into the mtd_info structure instead of several new entries, either we are on the master ("root") MTD device and we use the master's properties, or we are a partition and the partition properties will be used. Changes since v1: ================= * Commit name changed "proper partition handling" -> "rework partition tree". * Update mtd_get_device_size() to support recursive partitioning. * Remove part_*() helpers, update the corresponding mtd_*() helpers to handle the partitions themselves. * Drop the global partitions lock, add a lock per mtd_info but only use the root one to protect against partitions updates. ______________________________________________________ Linux MTD discussion mailing list http://lists.infradead.org/mailman/listinfo/linux-mtd/