Installing FreeDOS

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I would like to install the newly-released FreeDOS 1.3 into dosemu2
(on Ubuntu 21.10, x86-64.)

In fact, I would like to install *any* FreeDOS into it. :-) I have
installed the package `install-freedos` but it does not do what it
says -- in fact, it does not do anything. I think it installs some
scripts and the user must run them.

The entirety of the package description is:

A set of scripts to install freedos.
Also provides a set of bat files for dosemu2 integration.

It does not tell me what the scripts are, or where they are located,
or what to run, or what parameters are needed. There's no `man` page.
I can't find any info at all on the web, and there's no info on

So, I have been trying to work it out for myself, but so far, without
success. I would be very happy to write some README files for you,
maybe even a HOWTO or something, if I could work out what to do.

Looking at the package properties, I can see the following list of files:


There's no usage message if the batch files are invoked without
parameters. That would help! I was reasonably skilled with DOS batch
files 30 years ago, so if I can work this out, I can add that for you.

So, I tried `-?` which got me an informative error. Then I tried `-h`
and that got me some info.

Next I tried:

root@lproven:/usr/libexec/dosemu# ./dosemu-downloaddos freedos12

This downloads 9 files, then fails with this error:

Traceback (most recent call last):
  File "/usr/libexec/dosemu/./dosemu-downloaddos", line 205, in <module>
    download_dos(dos_to_download, destination)
  File "/usr/libexec/dosemu/./dosemu-downloaddos", line 170, in download_dos
    download_FREEDOS_FULL_ARCHIVES(FREEDOS12_URL, destination)
  File "/usr/libexec/dosemu/./dosemu-downloaddos", line 117, in
    download_file(freedos_url + '/repos/base/' + filename + '.zip', destination)
  File "/usr/libexec/dosemu/./dosemu-downloaddos", line 57, in download_file
    with urllib.request.urlopen(urllib.parse.quote_plus(source,
"\./_-:")) as response, open(destination_file, 'wb') as f:
  File "/usr/lib/python3.9/urllib/", line 214, in urlopen
    return, data, timeout)
  File "/usr/lib/python3.9/urllib/", line 523, in open
    response = meth(req, response)
  File "/usr/lib/python3.9/urllib/", line 632, in http_response
    response = self.parent.error(
  File "/usr/lib/python3.9/urllib/", line 561, in error
    return self._call_chain(*args)
  File "/usr/lib/python3.9/urllib/", line 494, in _call_chain
    result = func(*args)
  File "/usr/lib/python3.9/urllib/", line 641, in http_error_default
    raise HTTPError(req.full_url, code, msg, hdrs, fp)
urllib.error.HTTPError: HTTP Error 404: Not Found

I have looked in

... and it is true, there is no COMMAND.ZIP.

I don't know Python to any useful level, so fixing this script is
beyond me. Is there any other way I can proceed?

Liam Proven ~ Profile:
Email: lproven@xxxxxxxxx ~ gMail/gTalk/FB: lproven@xxxxxxxxx
Twitter/LinkedIn: lproven ~ Skype: liamproven
UK: (+44) 7939-087884 ~ Czech [+ WhatsApp/Telegram/Signal]: (+420) 702-829-053

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux