Weirdest thing ever

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Here's the thing: 
I'm using  a 64-bits dosemu. I tested that it could run our programs without problems on a test server running CentOS 5.4. Everything worked fine, so I tried to put it in our production server, running a 64-bits fedora 10. It didn't work. Dosemu hangs when it tries to execute dos4g.exe (it seems that it's a memory extender). Top shows  a processor maxing out on dosemu. 

I ran it with strace hoping to see if it entered a loop or something, and to my surprise then the program worked fine. And that's the thing, dosemu works as it should when I run it through strace, but  hangs when it should execute dos4g if I run it "normally". The uids/gids are the same, I've compared the memory maps and they are exactly the same and I don't know what else to compare. Anyone has any idea of why it is doing this, and how to make it work without strace? I know that the obvious thing would be installing the CentOS that's proved to work, but this server is on the other side of the country and I don't have physical access to it. Any ideas are welcomed.
To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux