Re: dosemu error -- LOWRAM mmap: Invalid argument

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Sat, Apr 17, 2010 at 10:28:06PM +0200, Danilo Godec wrote:
>On 7.4.2010 18:02, Mark S Bilk wrote:
>> When I run dosemu I get these error messages:
>>   LOWRAM mmap: Invalid argument
>>   Segmentation fault
>> I have already done this as root -- recommended as the 
>> solution for this problem -- but it doesn't help:
>>   echo 0 > /proc/sys/vm/mmap_min_addr
>> The dosemu version is, installed from an OpenSuse rpm.
>> I'm running OpenSuse Linux 11.2, kernel,
>> which is a 32-bit system.
>Disable 'apparmor' completely. Use the kernel boot option 'apparmor=0'
>to achieve that. (add it to /boot/grub/menu.lst).

Many thanks, Danilo -- that fixed it!

"rcapparmor stop" and "rcapparmor kill" did not help.  I had to 
add that kernel option and reboot.  The apparmor module is compiled 
into this kernel, but the option evidently deactivates it.

Dosemu actually ran a game!  Not any that I really want to run -- 
Apogee Crystal Caves, Secret Agent, and Cosmo.  But it's a start, 
and I can try various fixes, including modifying dosemu if I have to.


To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux