DPMI errors on amd64, but not on i386

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I'm using dosemu on Debian Lenny (compiled by myself as a 32 bit
executable). It works pretty well under a x86_32 2.6.26 kernel, running Windows
3.1 both in 286 & 386 mode, DJGPP, etc. 

However, whenever I boot a x86_64 kernel, command.com and the rest of 16-bit
applications run fine, but Windows and DJGPP do not. 

Windows only successfully boots every 100th time I launch it. Often, it just
shows "DPMI: Unhandheld Exception 0d"*. Sometimes it just hangs. After a
successful boot, it is also very buggy: Netscape (and most applications) tend to
crash due to page faults.

*Forcing 386 mode (win /d /3) results usually in DPMI Exception 06. Forcing 286
mode results in DPMI Exception 0d. 
Often, "ERROR: SMALLOC: bad pointer passed to smfree()" appears on dosemu's

I've tried the Debian packaged amd64 binary, but the result is the same.
I've also tried vm86dev for x86_64; "runcom" does indeed work, 16-bit
applications are faster, but windows does not boot either. 

To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux