On 10/20/2016 05:19 PM, Ulf Hansson wrote: > The code in __mmc_switch() is rather messy and hard to follow/understand. This > series starts out by cleaning-up and re-factoring that code. In the final patch > I intend to improve the behaviour regarding the polling method, which is being > used to know when the card stops signal busy. Looks good to me. Acked-by: Jaehoon Chung <jh80.chung@xxxxxxxxxxx> Tested-by: Jaehoon Chung <jh80.chung@xxxxxxxxxxx> (Tested on Exynos Series) Best Regards, Jaehoon Chung > > Ulf Hansson (4): > mmc: core: Make mmc_switch_status() available for mmc core > mmc: core: Clarify code which deals with polling in __mmc_switch() > mmc: core: Factor out code related to polling in __mmc_switch() > mmc: core: Don't use ->card_busy() and CMD13 in combination when > polling > > drivers/mmc/core/mmc.c | 13 ----- > drivers/mmc/core/mmc_ops.c | 138 +++++++++++++++++++++++++-------------------- > drivers/mmc/core/mmc_ops.h | 2 +- > 3 files changed, 79 insertions(+), 74 deletions(-) > -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html