The code in __mmc_switch() is rather messy and hard to follow/understand. This series starts out by cleaning-up and re-factoring that code. In the final patch I intend to improve the behaviour regarding the polling method, which is being used to know when the card stops signal busy. Ulf Hansson (4): mmc: core: Make mmc_switch_status() available for mmc core mmc: core: Clarify code which deals with polling in __mmc_switch() mmc: core: Factor out code related to polling in __mmc_switch() mmc: core: Don't use ->card_busy() and CMD13 in combination when polling drivers/mmc/core/mmc.c | 13 ----- drivers/mmc/core/mmc_ops.c | 138 +++++++++++++++++++++++++-------------------- drivers/mmc/core/mmc_ops.h | 2 +- 3 files changed, 79 insertions(+), 74 deletions(-) -- 1.9.1 -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html