[PATCH 2/3] mmc: Add a new mmc_is_io_op helper function

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



From: Carlo Caione <carlo@xxxxxxxxxxxx>

Add a helper function to check if an opcode is a sd-io-* opcode.

Signed-off-by: Carlo Caione <carlo@xxxxxxxxxxxx>
---
 drivers/mmc/core/sdio_ops.h | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/drivers/mmc/core/sdio_ops.h b/drivers/mmc/core/sdio_ops.h
index e4b5ceb..9b614b2 100644
--- a/drivers/mmc/core/sdio_ops.h
+++ b/drivers/mmc/core/sdio_ops.h
@@ -26,5 +26,10 @@ static inline bool mmc_is_rw_io_op(u32 opcode)
 	return opcode == SD_IO_RW_DIRECT || opcode == SD_IO_RW_EXTENDED;
 }
 
+static inline bool mmc_is_io_op(u32 opcode)
+{
+	return mmc_is_rw_io_op(opcode) || opcode == SD_IO_SEND_OP_COND;
+}
+
 #endif
 
-- 
2.5.0

--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux