On Sun, Apr 3, 2011 at 11:06 PM, Andrei Warkentin <andreiw@xxxxxxxxxxxx> wrote: > On Sat, Feb 12, 2011 at 12:22 AM, Chuanxiao Dong > <chuanxiao.dong@xxxxxxxxx> wrote: >> SDHCI host controller has TRIM/ERASE capability, enable these caps for erasing >> purpose. >> >> ERASE command needs R1B response. So for such command with busy signal, before >> sending command, SDHCI host driver will simply set a maximum value for timeout >> control register which is safe to use. >> > > Awesome. I took a look at the eMMC spec, and the following commands > also have R1B responses: > > 1) CMD5 (SLEEP_AWAKE) > 2) CMD6 (SWITCH) > 3) CMD7 (Select/Deselect - for Disconnected->Programming transitions) > 4) CMD12 (STOP_TRANSMISSION - for write case) > 5) CMD28 (SET_WRITE_PROT) > 6) CMD29 (CLR_WRITE_PROT) > > ...so this should help with timeouts for those commands as well. Thanks! > > A > On a second thought (and look), I see the following problems with this patch, which are otherwise going to make the MMC code confusing (and invalid). 1) Erase timeout value is defined by spec (eMMC or SD) and already calculated in mmc_set_erase_timeout within core/core.c. You should honor that value instead of picking the max timeout. 2) The trim/erase commands are not the only commands with variable timeouts. For example, certain CMD6 operations take different amounts of time (Partition switch takes ext_csd:PARTITION_SWITCH_TIME) Right now the command structure contains the field "erase_timeout", which curiously enough is used nowhere other than getting set in core/core.c. I propose renaming it to cmd_timeout. If cmd.data is NULL, then cmd_timeout is used to set timeout for busy-type commands. A -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html