Re: [RFC] [PATCH 1/2] mmc: split mmc_sd_init_card()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, 25 May 2010 18:10:28 +0200 (CEST)
Micha__ Miros__aw <mirq-linux@xxxxxxxxxxxx> wrote:

> This is needed to avoid code duplication in SD-combo support.

hm.  Perhaps you could have told us a bit more about it than this.

> +int mmc_sd_get_cid(struct mmc_host *host, u32 ocr, u32 *cid)
> +int mmc_sd_get_csd(struct mmc_host *host, struct mmc_card *card)
> +int mmc_sd_setup_card(struct mmc_host *host, struct mmc_card *card,
> +unsigned mmc_sd_get_max_clock(struct mmc_card *card)
> +void mmc_sd_go_highspeed(struct mmc_card *card)

These are global symbols, but they are not exported to (other) modules.
That's odd.  I'd have expected to see them either `static' or
EXPORT_MODULE()d.

I'll take the lack of a signed-off-by: and the "RFC" as signal to not
apply these patches.

--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux