On Tue, Oct 27, 2009 at 10:35 PM, Haavard Skinnemoen <haavard.skinnemoen@xxxxxxxxx> wrote: > Andrew Victor <avictor.za@xxxxxxxxx> wrote: >> > +static struct mci_platform_data __initdata mci0_data = { >> > + .slot[0] = { >> > + .bus_width = 4, >> > + .detect_pin = AT91_PIN_PD10, >> > + .wp_pin = -1, >> > + }, >> >> Causes at91_set_gpio_input() to be called for pin -1. Which shouldn't be valid. >> AT91 platforms use 0 to indicate an un-connected GPIO pin, so the >> assignment of "wp_pin" should probably just be removed. > > The mci driver expects non-existent pins to have a negative value, as > do all other drivers which use gpio_is_valid(). > Then I think it would be best to use GPIO_PIN_NONE. Makes it clear what is expected and avoids confusion on what should be the proper value. I hope I'm not saying non-sense, but even if I am, I guess you can see that I'm advocating against the magic numbers :) Kind Regards, Thiago A. Correa -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html