On (06/30/15 15:46), David Rientjes wrote: > > > There are essential elements to an oom context that are passed around to > > > multiple functions. > > > > > > Organize these elements into a new struct, struct oom_context, that > > > specifies the context for an oom condition. > > > > > > > s/oom_context/oom_control/ ? > > > > I think it would be confused with the existing memory.oom_control for > memcg. > Hello David, Sorry, I meant that in commit message you say :Organize these elements into a new struct, struct oom_context, that :specifies the context for an oom condition. but define and use `struct oom_control' (not `struct oom_context') [..] + const gfp_t gfp_mask = GFP_KERNEL; + struct oom_control oc = { + .zonelist = node_zonelist(first_memory_node, gfp_mask), + .nodemask = NULL, + .gfp_mask = gfp_mask, + .order = 0, + .force_kill = true, + }; + [..] +struct oom_control { + struct zonelist *zonelist; + nodemask_t *nodemask; + gfp_t gfp_mask; + int order; + bool force_kill; +}; [..] etc. -ss -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>