Re: [PATCH 05/13] mm: meminit: Make __early_pfn_to_nid SMP-safe and introduce meminit_pfn_in_nid

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Apr 27, 2015 at 03:43:33PM -0700, Andrew Morton wrote:
> On Thu, 23 Apr 2015 11:33:08 +0100 Mel Gorman <mgorman@xxxxxxx> wrote:
> 
> > __early_pfn_to_nid() in the generic and arch-specific implementations
> > use static variables to cache recent lookups. Without the cache
> > boot times are much higher due to the excessive memblock lookups but
> > it assumes that memory initialisation is single-threaded. Parallel
> > initialisation of struct pages will break that assumption so this patch
> > makes __early_pfn_to_nid() SMP-safe by requiring the caller to cache
> > recent search information. early_pfn_to_nid() keeps the same interface
> > but is only safe to use early in boot due to the use of a global static
> > variable. meminit_pfn_in_nid() is an SMP-safe version that callers must
> > maintain their own state for.
> 
> Seems a bit awkward.
> 

I'm afraid I don't understand which part you mean.

> > +struct __meminitdata mminit_pfnnid_cache global_init_state;
> > +
> > +/* Only safe to use early in boot when initialisation is single-threaded */
> >  int __meminit early_pfn_to_nid(unsigned long pfn)
> >  {
> >  	int nid;
> >  
> > -	nid = __early_pfn_to_nid(pfn);
> > +	/* The system will behave unpredictably otherwise */
> > +	BUG_ON(system_state != SYSTEM_BOOTING);
> 
> Because of this.
> 
> Providing a cache per cpu:
> 
> struct __meminitdata mminit_pfnnid_cache global_init_state[NR_CPUS];
> 
> would be simpler?
> 

It would be simplier in terms of implementation but it's wasteful. We
only need a small number of these caches early in boot. NR_CPUS is
potentially very large.

> 
> Also, `global_init_state' is a poor name for a kernel-wide symbol.

You're right. It's not really global, it's just the one that is used if
the caller does not track their own state. It should have been static and
I renamed it to early_pfnnid_cache.

-- 
Mel Gorman
SUSE Labs

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]