On Mon, Jan 26, 2015 at 09:49:47AM -0600, Christoph Lameter wrote: > On Mon, 26 Jan 2015, Vladimir Davydov wrote: > > > @@ -2400,11 +2400,16 @@ int __kmem_cache_shrink(struct kmem_cache *cachep) > > return (ret ? 1 : 0); > > } > > > > +void __kmem_cache_shrink(struct kmem_cache *cachep) > > +{ > > + __cache_shrink(cachep); > > +} > > + > > Why do we need this wrapper? Rename __cache_shrink to __kmem_cache_shrink > instead? > __cache_shrink() is used not only in __kmem_cache_shrink(), but also in SLAB's __kmem_cache_shutdown(), where we do need its return value to check if the cache is empty. Thanks, Vladimir -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>