On Wed 08-10-14 15:27:54, Michal Hocko wrote: > On Sat 20-09-14 16:00:33, Johannes Weiner wrote: [...] > > @@ -2803,8 +2808,10 @@ static void memcg_uncharge_kmem(struct mem_cgroup *memcg, > > page_counter_uncharge(&memcg->memsw, nr_pages); > > > > Wouldn't a single out_css_put be more readable? I was quite confused > when I start reading the patch before I saw the next hunk. Ohh, this will go away in the next patch. Ignore this. > > > /* Not down to 0 */ > > - if (page_counter_uncharge(&memcg->kmem, nr_pages)) > goto out_css_put; > > > + if (page_counter_uncharge(&memcg->kmem, nr_pages)) { > > + css_put_many(&memcg->css, nr_pages); > > return; > > + } > > > > /* > > * Releases a reference taken in kmem_cgroup_css_offline in case > > @@ -2816,6 +2823,8 @@ static void memcg_uncharge_kmem(struct mem_cgroup *memcg, > > */ > > if (memcg_kmem_test_and_clear_dead(memcg)) > > css_put(&memcg->css); > > + > > out_css_put: > > + css_put_many(&memcg->css, nr_pages); > > } > > > > /* > -- > Michal Hocko > SUSE Labs -- Michal Hocko SUSE Labs -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>