On Wed, 2014-08-13 at 00:52 +0300, Kirill A. Shutemov wrote: > On Tue, Aug 12, 2014 at 10:45:23AM -0700, Davidlohr Bueso wrote: > > The most common way of iterating through the list of vmas, is via: > > for (vma = mm->mmap; vma; vma = vma->vm_next) > > > > This patch replaces this logic with a new for_each_vma(vma) helper, > > which 1) encapsulates this logic, and 2) make it easier to read. > > Why does it need to be encapsulated? > Do you have problem with reading plain for()? > > Your for_each_vma(vma) assumes "mm" from the scope. This can be confusing > for reader: whether it uses "mm" from the scope or "current->mm". This > will lead to very hard to find bug one day. I think its fairly obvious to see where the mm is coming from -- the helpers *do not* necessarily use current, it uses whatever mm was already there in the first place. I have not changed anything related to this from the callers. The only related change I can think of, is for some callers that do: for (vma = current->mm->mmap; vma != NULL; vma = vma->vm_next) So we just add a local mm from current->mm and replace the for() with for_each_vma(). I don't see anything particularly ambiguous with that. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>