On Tue, Aug 12, 2014 at 10:45:23AM -0700, Davidlohr Bueso wrote: > The most common way of iterating through the list of vmas, is via: > for (vma = mm->mmap; vma; vma = vma->vm_next) > > This patch replaces this logic with a new for_each_vma(vma) helper, > which 1) encapsulates this logic, and 2) make it easier to read. Why does it need to be encapsulated? Do you have problem with reading plain for()? Your for_each_vma(vma) assumes "mm" from the scope. This can be confusing for reader: whether it uses "mm" from the scope or "current->mm". This will lead to very hard to find bug one day. I don't like this. > It also updates most of the callers, so its a pretty good start. > > Similarly, we also have for_each_vma_start(vma, start) when the user > does not want to start at the beginning of the list. And lastly the > for_each_vma_start_inc(vma, start, inc) helper in introduced to allow > users to create higher level special vma abstractions, such as with > the case of ELF binaries. for_each_vma_start_inc() is pretty much the plain for() but with really_long_and_fancy_name(). Why? -- Kirill A. Shutemov -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>